summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1556f48ab523
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=ctr-popsoundshaper-bin
+pkgver=1.7.2
+pkgrel=1
+arch=('x86_64')
+url="https://www.cutthroughrecordings.com/product/POP_Sound_Shaper"
+license=('EULA')
+depends=('glibc' 'libcurl-gnutls')
+makedepends=('xdg-user-dirs' 'unzip')
+pkgdesc="Cut Through Recordings Pop Sound Filter - Dynamic Filter (LV2/VST/VST3)"
+groups=('lv2-plugins' 'pro-audio' 'vst-plugins' 'vst3-plugins')
+
+package() {
+ mkdir -p "$pkgdir/usr/lib"/{lv2,vst,vst3}
+
+ ## Install LV2
+ ln -srf "`xdg-user-dir DOWNLOAD`/popss-LinuxLV2-64Bit.zip" "$srcdir/popss-LinuxLV2-64Bit.zip"
+ unzip "popss-LinuxLV2-64Bit.zip"
+ cp -r "$srcdir/POPSoundShaper.lv2" "$pkgdir/usr/lib/lv2/POPSoundShaper.lv2"
+
+ ## Install VST
+ ln -srf "`xdg-user-dir DOWNLOAD`/popss-LinuxVST-64Bit.zip" "$srcdir/popss-LinuxVST-64Bit.zip"
+ unzip "popss-LinuxVST-64Bit.zip"
+ install -Dm755 "$srcdir/Cut Through Recordings POP Sound Shaper.so" "$pkgdir/usr/lib/vst/Cut Through Recordings POP Sound Shaper.so"
+
+ ## Install VST3
+ ln -srf "`xdg-user-dir DOWNLOAD`/popss-LinuxVST3-64Bit.zip" "$srcdir/popss-LinuxVST3-64Bit.zip"
+ unzip "popss-LinuxVST3-64Bit.zip"
+ install -Dm755 "$srcdir/Cut Through Recordings POP Sound Shaper.vst3" "$pkgdir/usr/lib/vst3/Cut Through Recordings POP Sound Shaper.vst3"
+}