summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed4d070ad7cd..a33e94bdf8c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=cubbit
pkgdesc='Cubbit desktop-sync application'
-pkgver=8.0.2
+pkgver=9.5.1
pkgrel=1
arch=('x86_64')
url='https://www.cubbit.io/'
license=('custom')
depends=('gtk2' 'hicolor-icon-theme' 'libxss' 'libxtst')
+optdepends=('libappindicator-gtk2' 'libnotify')
options=('!strip')
source=("https://get.cubbit.io/desktop/linux/Cubbit-${pkgver}.AppImage")
-sha256sums=('96a32b692a1bac135247afb2a65537fafadf6f18a4496a6d03e22d4a47e9ad1d')
+sha256sums=('75b8c96818e3006f83509466b26def17d012312f819053d9c2673dbaacbf199b')
prepare() {
chmod +x Cubbit-${pkgver}.AppImage
@@ -30,18 +31,23 @@ package() {
install -Dm755 "$srcdir"/squashfs-root/@cubbitdesktop -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/icudtl.dat -t "$pkgdir"/usr/share/cubbit/
- install -Dm644 "$srcdir"/squashfs-root/chrome* -t "$pkgdir"/usr/share/cubbit/
+ install -Dm644 "$srcdir"/squashfs-root/chrome*.pak -t "$pkgdir"/usr/share/cubbit/
+ install -Dm755 "$srcdir"/squashfs-root/chrome_crashpad_handler -t "$pkgdir"/usr/share/cubbit/
+ install -Dm755 "$srcdir"/squashfs-root/chrome-sandbox -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/resources.pak -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/lib* -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/snapshot_blob.bin -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/v8_context_snapshot.bin -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/vk_swiftshader_icd.json -t "$pkgdir"/usr/share/cubbit/
install -Dm644 "$srcdir"/squashfs-root/locales/* -t "$pkgdir"/usr/share/cubbit/locales/
- install -Dm644 "$srcdir"/squashfs-root/resources/* -t "$pkgdir"/usr/share/cubbit/resources
+ install -Dm644 "$srcdir"/squashfs-root/resources/app-update.yml -t "$pkgdir"/usr/share/cubbit/resources
+ install -Dm644 "$srcdir"/squashfs-root/resources/app.asar -t "$pkgdir"/usr/share/cubbit/resources
+ install -Dm644 "$srcdir"/squashfs-root/resources/app.asar.unpacked/sql/migrations/* -t "$pkgdir"/usr/share/cubbit/resources/app.asar.unpacked/sql/migrations/
install -Dm644 "$srcdir"/squashfs-root/swiftshader/* -t "$pkgdir"/usr/share/cubbit/swiftshader/
install -d "$pkgdir"/usr/bin
install -Dm755 "$srcdir"/AppRun -T "$pkgdir"/usr/bin/@cubbitdesktop
+ install -Dm755 "$srcdir"/squashfs-root/bin/gozer -T "$pkgdir"/usr/bin/gozer
install -Dm644 "$srcdir"/squashfs-root/license.txt -t "$pkgdir"/usr/share/licenses/$pkgname
install -Dm644 "$srcdir"/squashfs-root/LICENSE.electron.txt -t "$pkgdir"/usr/share/licenses/$pkgname