summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e089b4cd491..81a9ea48aff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname="cups-nosystemd"
-pkgver=2.2.9
+pkgver=2.2.10
pkgrel=1
pkgdesc="The CUPS Printing System - daemon package"
arch=('i686' 'x86_64')
@@ -26,7 +26,6 @@ backup=(etc/cups/cupsd.conf
etc/cups/classes.conf
etc/cups/cups-files.conf
etc/cups/subscriptions.conf
- etc/dbus-1/system.d/cups.conf
etc/logrotate.d/cups
etc/pam.d/cups)
#etc/xinetd.d/cups-lpd)
@@ -37,7 +36,7 @@ source=(https://github.com/apple/cups/releases/download/v${pkgver}/cups-${pkgver
cups-no-gzip-man.patch
cups-1.6.2-statedir.patch
)
-sha256sums=('6d22d5da253b97643320da0bf95574acd85ff2abe3ec1a51d36093841d891156'
+sha256sums=('77c8b2b3bb7fe8b5fbfffc307f2c817b2d7ec67b657f261a1dd1c61ab81205bb'
'87cd833e7c07a36298341e35d5ce0534ce68fdf76ce3e9eda697e5455b963d1b'
'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
'57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
@@ -83,7 +82,8 @@ build() {
--with-cups-group=lp \
--enable-pam=yes \
--enable-raw-printing \
- --enable-dbus --with-dbusdir=/etc/dbus-1 \
+ --enable-dbus=yes \
+ --with-dbusdir=/usr/share/dbus-1 \
--enable-ssl=yes \
--enable-threads \
--enable-avahi \
@@ -122,6 +122,11 @@ package() {
touch "$pkgdir"/etc/cups/subscriptions.conf
chgrp -R lp "$pkgdir"/etc/cups
+ # fix dbus policy location - --with-dbusdir doens't work
+ install -dm755 "$pkgdir"/usr/share/dbus-1/system.d
+ mv "$pkgdir"/etc/dbus-1/system.d/cups.conf ${pkgdir}/usr/share/dbus-1/system.d
+ rm -rf "$pkgdir"/etc/dbus-1
+
# fix .desktop file
sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' "$pkgdir"/usr/share/applications/cups.desktop