summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc9f882f7e64..8d49c2f42510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=15.06.03
-pkgrel=4
+pkgver=2.1.0
+pkgrel=1
pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
depends=('qt5-svg' 'python-pyserial' 'python-numpy' 'uranium' 'curaengine')
makedepends=('qt5-tools' 'cmake')
@@ -10,15 +10,15 @@ provides=('cura')
url="https://ultimaker.com/en/products/cura-software"
license=('AGPLv3')
arch=('i686' 'x86_64')
-source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz site-packages-dir.patch)
-sha1sums=('d03d3e86fd40de6e791301b696c8c53ae288faa7'
- 'a1a21f761ababccf366ce100c536b21e83c69fb9')
+source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz fix-python-dir.patch)
+sha1sums=('ac5893d13630bc85176c50c49244b6461ccb54f4'
+ '439a5efb8371bbfd1266a6b6434c0584f00baaa9')
install=cura.install
prepare(){
cd Cura-${pkgver}
- patch -Np1 -i ../site-packages-dir.patch
+ patch -Np1 -i ../fix-python-dir.patch
cat > ${pkgname}.desktop <<END
[Desktop Entry]
@@ -40,12 +40,18 @@ build(){
package(){
cd Cura-${pkgver}
make DESTDIR="${pkgdir}" install
+
+ # make sure cura can find uranium plugins:
+ ln -s /usr/lib/uranium/plugins/* "${pkgdir}/usr/lib/cura/plugins/."
+
+ # don't ever send any user or print info through the internet to Ultimaker
+ rm -rf "${pkgdir}/usr/lib/cura/plugins/SliceInfoPlugin"
# install .desktop file
install -D -t ${pkgdir}/usr/share/applications ${pkgname}.desktop
# rename executable
- mv ${pkgdir}/usr/bin/cura_app.py ${pkgdir}/usr/bin/cura
+ #mv ${pkgdir}/usr/bin/cura_app.py ${pkgdir}/usr/bin/cura
}