summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef4ac456640
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kevin McCormack <harlemsquirrel@gmail.com>
+pkgname=cura-lulzbot
+pkgver=3.2.23
+pkgrel=1
+pkgdesc='Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.'
+arch=('x86_64')
+url='https://www.lulzbot.com/cura'
+license=('AGPLv3')
+source=("http://download.alephobjects.com/ao/aodeb/dists/stretch/main/binary-amd64/cura-lulzbot_${pkgver}_amd64.deb")
+md5sums=('f7d72032890f5479b7cc7d650ca13600')
+depends=('gcc6-fortran')
+
+prepare() {
+ # Unpack the tarball containing the 'usr/' directory,
+ # where all the essentials reside within the debian package
+ tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+
+ sed -i 's;LD_LIBRARY_PATH=;LD_LIBRARY_PATH=/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.1:;' "${srcdir}/usr/bin/cura-lulzbot"
+}
+
+package() {
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}
+
+## Update .SRCINFO
+# makepkg --printsrcinfo | tee .SRCINFO