summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95f3be9c835c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=curtail-git
+pkgver=1.1.0+2+g6918486
+pkgrel=1
+pkgdesc="Simple & lossless image compressor."
+arch=('any')
+url="https://github.com/Huluti/Curtail"
+license=('GPL3')
+depends=('gtk3' 'python-gobject' 'jpegoptim' 'optipng' 'pngquant')
+makedepends=('meson')
+checkdepends=('appstream-glib')
+provides=('curtail')
+conflicts=('curtail' 'imcompressor')
+source=("git+https://github.com/Huluti/Curtail.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd Curtail
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson Curtail build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}