summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35342b472574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ali Nabipour <alinabipour01@gmail.com>
+
+pkgname=cutefish-core-git
+_pkgname=cutefish-core
+pkgver=0.3.r42.g9c18511
+pkgrel=1
+pkgdesc="System components and backend of CutefishOS"
+arch=('x86_64')
+url="https://github.com/cutefishos/core"
+license=('GPL')
+groups=('cutefish-git')
+depends=('fishui-git' 'libpulse' 'libxtst' 'polkit-qt5')
+makedepends=('extra-cmake-modules' 'ninja' 'qt5-tools' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd core
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd core
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd core
+ make DESTDIR="$pkgdir" install
+}