summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 811ff2811811..26dee81523ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=cutemaze
-pkgver=1.3.0
+pkgver=1.3.3
pkgrel=1
pkgdesc='Top-down maze game'
arch=('x86_64')
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base' 'qt6-svg')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('87bf87d84dfb6554a794f6ba203fa5344bc5b54e4f7dd3129418ea06e9a88e85')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('5af6de035ce0686c791f0e49798ad85fbd8c270dcebb556701b07a47a634469c')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}