summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80cd995926f8..ed826450554c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Petar Benke <makepkg@benke.co.uk>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Petar Benke <makepkg@benke.co.uk>
+
pkgname=cutmp3
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="Edit mp3 (and mp2) files without quality loss"
-arch=('i686' 'x86_64')
-url="http://www.puchalla-online.de/cutmp3.html"
+arch=('any')
+url="https://www.puchalla-online.de/cutmp3.html"
license=('GPL')
depends=('readline')
-source=("http://www.puchalla-online.de/$pkgname-$pkgver.tar.bz2")
-md5sums=('SKIP')
+source=("https://github.com/tarjanm-movidius/cutmp3/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9b949de184570698b00c001f8762f4c507b6b4e86fe9ac362ca6250bcd8f08d2')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
+ CFLAGS=-Wno-error=format-security
make
}
package() {
- cd "$pkgname-$pkgver"
- make PREFIX="$pkgdir/usr" install
+ cd "${pkgname}-${pkgver}"
+ make PREFIX="${pkgdir}/usr" install
}