summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d44313a014f1..21fc6b48b164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Konstantin Gizdov < arch at kge dot pw >
pkgname=cvmfs
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A client-server file system implemented in FUSE and developed to deliver software distributions onto virtual machines in a fast, scalable, and reliable way."
arch=('x86_64')
url="http://cernvm.cern.ch/portal/filesystem"
@@ -17,11 +17,13 @@ options=('!emptydirs')
source=("https://ecsft.cern.ch/dist/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
'settings.cmake'
'externals.patch'
- 'sqlite-scratch.patch')
+ 'sqlite-scratch.patch'
+ 'xattr.patch')
md5sums=('d46705e06267278fd3a65b277a6d9e16'
'20dc60c61077f4a3711463e8686d260d'
'109a95cab95276c1c19bc46b66f0906f'
- '0ef4c858aa9648dcd46768991748eb06')
+ '0ef4c858aa9648dcd46768991748eb06'
+ '08a46f14c08fe50b8d7cd33ec95ddda8')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -33,6 +35,9 @@ prepare() {
# Sqlite deprecated the SCRATCH configuration option
patch -Np1 -i "$srcdir/sqlite-scratch.patch"
+
+ # Do not use attr/xattr.h as it is not installed in Arch
+ patch -Np1 -i "$srcdir/xattr.patch"
}
build() {