summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c9edc610038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=cweather
+pkgbase=cweather
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Simple weather utility written in C - read the source code for more info"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('cjson' 'curl')
+optdepends=('nerd-fonts: for the expanded icon set')
+provides=('cweather')
+source=("git+https://github.com/raptor8134/cweather.git")
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgbase}
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cd ${srcdir}/${pkgbase}
+ make DESTDIR="${pkgdir}/" install
+}