summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11c44ab38cf5..80645778067b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blooser <blooser@protonmail.com>
pkgname=cygnus
pkgver=1.3
-pkgrel=2
+pkgrel=3
pkgdesc="RSS reader"
arch=('x86_64')
md5sums=('26cfda2c5b20496debe039d94207404d')
@@ -40,13 +40,15 @@ package() {
mv $pkgname-$pkgver $pkgname
cp -r $pkgname ~/Documents
rm -rf $pkgname
- if [ ! -f ~/.local/share/applications ]; then
+ if [ -f ~/.local/share/applications ]; then
mkdir ~/.local/share/applications
fi
echo "${shortcut}" > ~/.local/share/applications/cygnus.desktop
- if [ -f ~/.zshrc ]; then
- echo "alias cygnus=${applocation}/run.sh" >> ~/.zshrc
- else
- echo "alias cygnus=${applocation}/run.sh" >> ~/.bashrc
- fi
+ if type "cygnus" > /dev/null; then
+ if [ -f ~/.zshrc ]; then
+ echo "alias cygnus=${applocation}/run.sh" >> ~/.zshrc
+ else
+ echo "alias cygnus=${applocation}/run.sh" >> ~/.bashrc
+ fi
+ fi
}