summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aeeca7ebfea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# PKGBUILD file for Arch Linux packaging
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+
+pkgname=danmaku2ass-git
+pkgver=20140615
+pkgrel=1
+pkgdesc="Convert comments from Niconico/AcFun/bilibili to ASS format"
+arch=('any')
+url="https://github.com/m13253/danmaku2ass"
+license=('GPL3')
+depends=('python>=3')
+makedepends=('git')
+provides=('danmaku2ass')
+conflicts=('danmaku2ass')
+source=('danmaku2ass::git://github.com/m13253/danmaku2ass.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/danmaku2ass"
+ git log -1 --format="%cd" --date=short | tr -d -
+}
+
+package() {
+ cd "$srcdir/danmaku2ass"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}