summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 23 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1d47e5d83d3..5e9092cc4612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,42 @@
# Contributor: Paul Bredbury <brebs@sent.com>
pkgname=darkplaces
-pkgver=20110628
-pkgrel=2
+pkgver=20121222
+pkgrel=1
pkgdesc="An advanced Quake 1 game engine"
arch=('i686' 'x86_64')
url="http://icculus.org/twilight/darkplaces/"
license=('GPL2')
-depends=('alsa-lib' 'libjpeg6' 'libxpm' 'libxxf86vm' 'libxxf86dga' 'sdl')
+depends=('alsa-lib' 'hicolor-icon-theme' 'libjpeg-turbo' 'libxpm' 'libxxf86vm' 'sdl')
makedepends=('xextproto' 'xf86dgaproto' 'xf86vidmodeproto' 'xproto')
install=$pkgname.install
source=(http://icculus.org/twilight/$pkgname/files/darkplacesengine$pkgver.zip
$pkgname.desktop)
-md5sums=('c42103732cedfcf385ee959db9db6cb4'
- '31dd47a4969ad5d9d0e1c59db1d0e1e2')
+sha256sums=('13f3a2e5703cc6de1006d071dbdfd44627ead21425df35a3a9eb525e4b8c439f'
+ '476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
build() {
- # Extract the package
- cd $srcdir
- bsdtar -xf darkplacesenginesource$pkgver.zip || return 1
+ # Extract the package
+ cd $srcdir
+ bsdtar -xf darkplacesenginesource$pkgver.zip || return 1
- # Make sure Darkplaces is not compiled with -j > 1.
- MAKEFLAGS="${MAKEFLAGS} -j1"
+ # Make sure Darkplaces is not compiled with -j > 1.
+ MAKEFLAGS="${MAKEFLAGS} -j1"
- # Compile
- cd $pkgname
- sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
+ # Compile
+ cd $pkgname
+ sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
+}
- # Install binary, icon and desktop files
- install -d $pkgdir/usr/{bin,share/quake}
- install -m 755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin/
+package() {
+ cd $srcdir/$pkgname
+ install -d $pkgdir/usr/{bin,share/quake}
+ install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
- for i in 16 24 32 48 64 72 ; do
- install -Dm 644 darkplaces${i}x$i.png $pkgdir/usr/share/icons/hicolor/${i}x$i/apps/darkplaces.png
- done
+ for i in 16 24 32 48 64 72; do
+ install -Dm644 darkplaces${i}x${i}.png $pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/darkplaces.png
+ done
- install -Dm 644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}