summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 12f5c83ee544..59daf33ca6c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=darkplaces-xonotic
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced Quake 1 game engine (Xonotic branch)"
arch=('i686' 'x86_64')
url="http://icculus.org/twilight/darkplaces/"
@@ -21,23 +21,17 @@ sha256sums=('61c2225e7a740af3111e4ebb260d7aceddd7e1f3e632b39f6dae22150097c431'
'476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
build() {
- # Extract the package
cd "${srcdir}/${pkgname}-v${pkgver}"
- # Make sure Darkplaces is not compiled with -j > 1.
- MAKEFLAGS="${MAKEFLAGS} -j1"
-
# Compile
- sed -i -e '1i DP_LINK_TO_LIBJPEG=1' makefile
- #make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake release || return 1
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake cl-release
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake sdl2-release
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/quake sv-release
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 cl-release
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 sdl2-release
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake DP_LINK_TO_LIBJPEG=1 sv-release
}
package() {
cd "${srcdir}/${pkgname}-v${pkgver}"
- install -d $pkgdir/usr/{bin,share/quake}
+ install -d $pkgdir/usr/{bin,share/games/quake}
install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
for i in 16 24 32 48 64 72; do