summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71dc97a2d2ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer : Jens Staal <staal1978@gmail.com>
+# Adapted from: Dan McGee <dan@archlinux.org>
+
+pkgname=dash-static-musl
+_pkgbase=dash
+pkgver=0.5.8
+pkgrel=1
+pkgdesc="A POSIX compliant shell that aims to be as small as possible, statically linked to musl libc"
+arch=('i686' 'x86_64')
+url="http://gondor.apana.org.au/~herbert/dash/"
+license=('BSD')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+makedepends=('musl') #we are static
+install=dash.install
+source=("http://gondor.apana.org.au/~herbert/dash/files/${_pkgbase}-${pkgver}.tar.gz")
+sha1sums=('cd058935bba545427caa375337afe8a6309477d2')
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ export CC=musl-gcc
+ export CFLAGS='-Os -static'
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man \
+ --exec-prefix="" \
+ --with-libedit
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # license
+ install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${_pkgbase}/COPYING
+}
+