summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 25 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4da1d9972116..34e5d23a235f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: GreenRaccoon23 <GreenRaccoon23 AT gmail DOT com>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: GreenRaccoon23 <GreenRaccoon23 AT gmail DOT com>
# Based on PKGBUILD from vertcoin-git maintained by Lothar_m <lothar_m AT riseup DOT net>
# WARNING: Use the `dashcore` package instead of this one unless you know what
# you are doing. The `dashcore` package provides the official, supported, tested,
@@ -8,34 +9,43 @@
pkgname='dashcore-git'
_gitname='dash'
_gitbranch='master'
-pkgver=13337.86525601d
+pkgver=v0.14.0.5.r0.g2ae1ce480
pkgrel=1
-arch=('i686' 'x86_64')
-url="https://www.dash.org/"
+arch=('x86_64')
+url="https://github.com/dashpay/dash"
depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'openssl')
-makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'git' 'qrencode' 'automoc4' 'protobuf' 'qt5-tools')
+makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'git' 'qrencode' 'protobuf' 'qt5-tools' 'python3' 'cmake' 'libevent')
license=('MIT')
pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version."
provides=('dashd' 'dash-qt' 'dash-cli')
-conflicts=('dashcore')
+conflicts=('dashcore' 'dashcore-bin')
source=("git://github.com/dashpay/dash.git")
sha512sums=('SKIP')
+prepare () {
+ cd "$_gitname"
+ git pull origin v0.14.0.x
+ #deque patch 2020-02-12
+ #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
+ #will delete when dash fixes/commits this.
+ patch --forward --strip=1 --input="../../deque.patch"
+}
+
pkgver() {
- cd "$srcdir/$_gitname"
- git checkout "$_gitbranch" -q
- git pull -q
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "$_gitname"
+( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
CXXFLAGS+=" -fPIC -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
- cd "$srcdir/$_gitname"
- git checkout "$_gitbranch"
- git pull
-
+ cd "$_gitname"
+ CPPFLAGS="${CPPFLAGS} -I$PWD/depends/built/x86_64-pc-linux-gnu/include"
+ LDFLAGS="${LDFLAGS} -L${PWD}/depends/built/x86_64-pc-linux-gnu/lib -L${PWD}/depends/built/x86_64-pc-linux-gnu/lib64"
./autogen.sh
- ./configure --with-incompatible-bdb --with-gui=qt5 --enable-tests=no
+ ./configure --prefix=`pwd`/depends/$CARCH-pc-linux-gnu --with-incompatible-bdb --with-gui=qt5 --enable-tests=no --enable-hardening
make
}