summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 529bfbf0a9c4..fb2d1f75f4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
_orgname=ericfischer
_pkgname=datamaps
_branch=master
+_with_parser=true
pkgname=${_pkgname}-git
pkgver=r290.76e620a
pkgrel=1
@@ -10,11 +11,18 @@ arch=('i686' 'x86_64')
url='https://github.com/ericfischer/datamaps'
license=('BSD')
depends=('libpng')
+if [ "${_with_parser}" = true ]; then
+ depends+=('perl-xml-parser')
+fi
makedepends=('git')
provides=("${pkgname//-git}=${pkgver}")
conflicts=(${pkgname//-git})
source=("${_pkgname}-${_branch}::git://github.com/${_orgname}/${_pkgname}.git#branch=${_branch}")
sha256sums=('SKIP')
+if [ "${_with_parser}" = true ]; then
+ source+=("https://raw.githubusercontent.com/${_orgname}/gpx-layer/master/parse-gpx")
+ sha256sums+=('SKIP')
+fi
pkgver() {
cd ${_pkgname}-${_branch}
@@ -26,9 +34,7 @@ pkgver() {
}
build() {
- cd ${_pkgname}-${_branch}
-
- make
+ make -C ${_pkgname}-${_branch}
}
package() {
@@ -37,5 +43,8 @@ package() {
for tool in encode enumerate merge render; do
install -Dm755 ${tool} ${pkgdir}/usr/bin/${_pkgname}-${tool}
done
+ if [ "${_with_parser}" = true ]; then
+ install -Dm755 ../parse-gpx ${pkgdir}/usr/bin/${_pkgname}-parse-gpx
+ fi
install -Dm644 LICENSE.md ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
}