summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f42c7657c928..aaaa401e2c47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
_pkgname=daty
+_commit=81b97361
pkgname=$_pkgname-git
-pkgver=0.1
+pkgver=1.0beta+78+g81b9736
pkgrel=1
pkgdesc='Daty Wikidata Editor'
url='https://gitlab.gnome.org/World/daty'
license=('AGPLv3')
arch=('any')
depends=('libhandy' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
source=('daty::git+https://gitlab.gnome.org/World/Daty.git')
-sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
package() {
cd "${_pkgname}"
python3 setup.py install --root="${pkgdir}" --optimize=1
}
+
+check() (
+ glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/$_pkgname/data}"
+ export GSETTINGS_SCHEMA_DIR
+)