summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c74e22a7f44..1839cc253e9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Jon Ribeiro <contact@jonathas.com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Jon Ribeiro <contact@jonathas.com>
pkgname=dbf
pkgver=0.9.0
-pkgrel=3
+pkgrel=4
pkgdesc="Command line tool to show and convert the content of dBASE III, IV, and 5.0 files"
url="http://sourceforge.net/projects/dbf"
arch=('i686' 'x86_64')
@@ -13,14 +14,16 @@ sha512sums=('f22a81038b44b9d8004c1ec058d00326dca76ee835718358faf15da91ed2716d6d7
build() {
cd "${srcdir}/$pkgname-core"
- chmod +x autogen.sh
- rm configure install-sh depcomp missing
- ./autogen.sh && ./configure --prefix=/usr
- make || return 1
+ rm -f configure install-sh depcomp missing
+ sed -r -i 's,AM_GLIB_GNU_GETTEXT,AM_GNU_GETTEXT_VERSION([0.19.8])\nAM_GNU_GETTEXT([external]),' configure.in
+ mv configure.in configure.ac
+ autoreconf -fiv
+ intltoolize --copy --force
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/$pkgname-core"
- make DESTDIR="${pkgdir}" install
- find "${pkgdir}" -name '*.la' -exec rm {} \;
+ cd "${srcdir}/$pkgname-core"
+ make DESTDIR="${pkgdir}" install
}