summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e554c59496e3..0de38585d481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=dbus-git
-pkgver=1.15.4.r31.ga6654eae
+pkgver=1.15.8.r17.gd9756df2
pkgrel=1
pkgdesc="Message bus system"
arch=('i686' 'x86_64')
url="https://www.freedesktop.org/wiki/Software/dbus/"
license=('GPL' 'custom')
-depends=('glibc' 'audit' 'expat' 'systemd-libs')
-makedepends=('git' 'autoconf-archive' 'systemd')
-provides=("dbus=$pkgver" 'libdbus')
+depends=('glibc' 'audit' 'expat' 'libaudit.so' 'libsystemd.so' 'systemd-libs')
+makedepends=('git' 'meson' 'systemd')
+provides=("dbus=$pkgver" 'libdbus' 'libdbus-1.so')
conflicts=('dbus' 'libdbus')
options=('staticlibs')
source=("git+https://gitlab.freedesktop.org/dbus/dbus.git"
@@ -27,34 +27,34 @@ pkgver() {
build() {
cd "dbus"
- NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix="/usr" \
+ meson setup \
+ --buildtype=plain \
+ --prefix="/usr" \
--sysconfdir="/etc" \
--localstatedir="/var" \
--libexecdir="/usr/lib/dbus-1.0" \
- --with-system-pid-file="/run/dbus/pid" \
- --with-system-socket="/run/dbus/system_bus_socket" \
- --with-console-auth-dir="/run/console" \
- --with-systemdsystemunitdir="/usr/lib/systemd/system" \
- --with-dbus-user="dbus" \
- --enable-systemd \
- --enable-user-session \
- --enable-epoll
- make
+ -Ddefault_library="both" \
+ -Dsystem_pid_file="/run/dbus/pid" \
+ -Dsystem_socket="/run/dbus/system_bus_socket" \
+ -Ddbus_user="dbus" \
+ -Depoll="enabled" \
+ -Dsystemd="enabled" \
+ "_build"
+ meson compile -C "_build"
}
check() {
cd "dbus"
- make check
+ #meson test -C "_build"
}
package() {
cd "dbus"
- make DESTDIR="$pkgdir" install
+ meson install -C "_build" --destdir "$pkgdir"
- rm -r "$pkgdir"/{etc,usr/share/doc,var}
+ rm -r "$pkgdir"/{etc,usr/share/doc,run,var}
install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/dbus"