summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcb9433f02fe..f167330c524b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,22 @@
# Contributor: Link Dupont <link@subpop.net>
pkgname=dbus-x11
-pkgver=1.10.14
+pkgver=1.10.18
pkgrel=1
pkgdesc="Freedesktop.org message bus system"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(i686 x86_64)
license=(GPL custom)
-provides=('libdbus' 'dbus')
-conflicts=('libdbus' 'dbus')
+provides=('libdbus' 'dbus' 'dbus-docs')
+conflicts=('libdbus' 'dbus' 'dbus-docs')
replaces=(libdbus)
depends=(libsystemd expat)
makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen git libx11)
-_commit=449d6b313d2023360cf0af063cf23232901dd00b # tags/dbus-1.10.14^0
+_commit=73961ee58cf47315b14e30fbde6d0eea825c987b # tags/dbus-1.10.18^0
source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit"
- 0001-Drop-Install-sections-from-user-services.patch)
+ 'dbus.sysusers')
sha256sums=('SKIP'
- '48135124680bd9ea2d7d2bd2a9f457608d97bd9aa7cb4f4396e26a1c2c91af3e')
+ '1ce179ba3a92ad34941d8ac7f53d01d42cbc91d43ada1136492b78c10b5d693d')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
'3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
@@ -31,7 +31,7 @@ pkgver() {
prepare() {
cd ${pkgname%-*}
- patch -Np1 -i ../0001-Drop-Install-sections-from-user-services.patch
+ git cherry-pick -n 09cb6d7b467f6d1c6685ee9ccc171f4dddbe1f42
NOCONFIGURE=1 ./autogen.sh
}
@@ -64,6 +64,14 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/${pkgname%-*}/COPYING"
+ # systemd-sysusers
+ install -Dm644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+
# Split docs
mv "$pkgdir/usr/share/doc" "$srcdir"
+
+ install -d "$pkgdir/usr/share/licenses"
+ ln -s dbus "$pkgdir/usr/share/licenses/dbus-docs"
+
+ mv doc "$pkgdir/usr/share"
}