summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a945dc4c6d0..b75a47096c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Peter Lamby <peterlamby@web.de>
pkgname=deadbeef-mpris2-plugin
-pkgver=1.13
+pkgver=1.16
pkgrel=1
pkgdesc="MPRISv2 plugin for the DeaDBeeF music player"
arch=('i686' 'x86_64')
-url="https://github.com/Serranya/deadbeef-mpris2-plugin"
+url="https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin"
license=('GPL2')
depends=('glib2' 'deadbeef' )
conflicts=('deadbeef-mpris-plugin')
options=('!libtool')
-source=(https://github.com/Serranya/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz)
-md5sums=('848323d88f9b781d6c6e6dbf9a4e04c8')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz)
+md5sums=('c7943dcb8e723d01edb621b74a37ba14')
build() {
- cd "${srcdir}/deadbeef-${pkgver}"
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf --install
+ ./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/deadbeef-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}