summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29ce6a4d06ae..be662eea5324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp Uhl <philipp.uhl@rwth-aachen.de>
pkgname=deadd-notification-center-bin
-pkgver=1.7.3
-pkgrel=1
+pkgver=2.1.1
+pkgrel=2
pkgdesc="Customizable notification-daemon with notification center"
url="https://github.com/phuhl/linux_notification_center"
license=("BSD")
@@ -10,10 +10,15 @@ arch=('x86_64')
depends=('gobject-introspection-runtime' 'gtk3')
provides=('deadd-notification-center')
conflicts=('deadd-notification-center' 'deadd-notification-center-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/linux_notification_center/archive/${pkgver}.tar.gz")
+DLAGENTS=('https::/usr/bin/curl -L -o %o %u')
+source=(
+ "deadd-notification-center::https://github.com/phuhl/linux_notification_center/releases/download/${pkgver}/deadd-notification-center"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/linux_notification_center/archive/refs/tags/${pkgver}.tar.gz")
prepare() {
tar -zxvf "${pkgname}-${pkgver}.tar.gz"
+ mkdir "linux_notification_center-${pkgver}/.out"
+ mv deadd-notification-center "linux_notification_center-${pkgver}/.out/deadd-notification-center"
}
build() {
@@ -22,7 +27,9 @@ build() {
package() {
cd "linux_notification_center-${pkgver}"
+ make service
make DESTDIR="$pkgdir" install
}
-md5sums=('bb2d4739a65c3c7bed3d655d231351bf')
+sha256sums=('eb45d81288a13ee26733db8c9f08b40261304f8eb2ea9667f36343d079c666e4'
+ 'e83cae52aff076da8f199d64580e921eeab029aca6214937ab38a6c43145862b')