summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e67758d963c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philipp Uhl <philipp.uhl@rwth-aachen.de>
+
+pkgname=deadd-notification-center-bin
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Customizable notification-daemon with notification center"
+url="https://github.com/phuhl/linux_notification_center"
+license=("BSD")
+arch=('x86_64')
+depends=('gobject-introspection-runtime' 'gtk3')
+conflicts=('deadd-notification-center')
+makedepends=('stack' 'cairo' 'pango' 'gobject-introspection')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phuhl/linux_notification_center/archive/${pkgver}.tar.gz")
+prepare() {
+ tar -zxvf "${pkgname}-${pkgver}.tar.gz"
+}
+build() {
+ cd "linux_notification_center-${pkgver}"
+}
+
+package() {
+ cd "linux_notification_center-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('6b367f8187d0f71633fc22d47b6dd2cf')