summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b575eaffa6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philipp Uhl <philipp.uhl@rwth-aachen.de>
+
+_gitname="linux_notification_center"
+pkgname=deadd-notification-center-git
+pkgver=1.7.3.r0.g2aacce2
+pkgrel=1
+pkgdesc="Customizable notification-daemon with notification center"
+url="https://github.com/phuhl/linux_notification_center"
+license=("BSD")
+arch=('x86_64')
+depends=('gobject-introspection-runtime' 'gtk3')
+makedepends=('stack' 'cairo' 'pango' 'gobject-introspection')
+provides=('deadd-notification-center')
+conflicts=('deadd-notification-center-bin' 'deadd-notification-center')
+source=("git+${url}.git#branch=master")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="$pkgdir" install
+}
+