summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91df773336dc..3c00ef4529c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Contributor: Daniel Milde <info@milde.cz>
pkgname=deditor
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="The editor that boosts your python development"
url="https://launchpad.net/deditor"
license=(GPL)
arch=('i686' 'x86_64')
-depends=('python2' 'wxpython' 'paramiko')
+depends=('python2' 'wxpython' 'python2-paramiko')
source=(http://launchpad.net/deditor/0.x/${pkgver}/+download/deditor_${pkgver}_all.deb
'deditor.desktop'
'deditor.sh')
-md5sums=('5ab2ea783863ebf2af42964d78f1fa03'
- '90fb088dcb04194273428e67226fda2e'
+md5sums=('791411f0543f21c80f6801f8fc36abba'
+ 'f7d3479ee9342e3cee8de04d1b0d7dde'
'22a730764194046734749a954dcfbd4f')
-build() {
+package() {
cd ${srcdir}
ar x deditor_${pkgver}_all.deb
tar xzf data.tar.gz
mv ./usr ${pkgdir}
chmod -R 755 ${pkgdir}
- chmod 777 ${pkgdir}/usr/share/deditor/pluginconf.ded
install -D -m755 ${srcdir}/deditor.sh ${pkgdir}/usr/bin/${pkgname}
+ chmod 777 ${pkgdir}/usr/share/deditor/config/deditor.dpc
+ install -D -m755 ${srcdir}/deditor.desktop ${pkgdir}/usr/share/applications/deditor.desktop
sed -i 's/env python/python2/' ${pkgdir}/usr/share/deditor/deditor.py
}