summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90189b842a67..e970e380aa12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,45 @@
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
-# Previous Maintainer: Denis Meiswinkel <denis.meiswinkel@gmail.com>
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contributor: Denis Meiswinkel <denis.meiswinkel@gmail.com>
# Contributor: Balló György <ballogyor+arch@gmail.com>
pkgname=dee
pkgver=1.2.7
pkgrel=11
-pkgdesc="Model to synchronize multiple instances over DBus."
-arch=("i686" "x86_64")
+pkgdesc="Model to synchronize multiple instances over DBus"
+arch=("x86_64")
url="https://launchpad.net/dee"
license=("LGPL")
depends=("glib2" "icu")
-makedepends=("gobject-introspection" "python2" "vala")
+makedepends=("gobject-introspection" "python" "vala")
source=("https://launchpad.net/${pkgname}/1.0/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
- "https://launchpadlibrarian.net/258481465/fix-misleading-indentation.patch")
+ dee-1.2.7-gcc6-fixes.patch
+ dee-1.2.7-deprecated-g_type_class_add_private.patch
+ vapi-skip-properties.patch)
sha256sums=('1bf0336ce684aa0f48d6eae2469628c1a9b43695a77443bc31a5790aa673bf8a'
- '3bf75bd632d6be88632c0f6113aac5ac5d65e1a01b408c27ea1fd7bb718d6ebd')
+ '0a97d52b6c1e63ac070d9870914b1741d0bd2cd69f179c6a8ae69d0482905d38'
+ 'e9be91ded88cbb8256ea71d20a71be6ca8e304bc971902e28ffe9bba0ac1dc05'
+ 'ba0f9f80e3827fc4e1e546e4011982512b5b09e8f66496b213a4bd319bf829f5')
prepare() {
- cd $srcdir
- patch -p1 -i $srcdir/fix-misleading-indentation.patch
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i ../dee-1.2.7-gcc6-fixes.patch
+ patch -Np1 -i ../dee-1.2.7-deprecated-g_type_class_add_private.patch
+ patch -Np1 -i ../vapi-skip-properties.patch
+ autoreconf -fi
}
build() {
cd ${pkgname}-${pkgver}
- export PYTHON="/usr/bin/python2"
+ export PYTHON="/usr/bin/python"
./configure --prefix="/usr" --sysconfdir="/etc" --localstatedir="/var" --disable-{static,tests}
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd $pkgname-$pkgver
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
-
-# Is this useful? Fedora does not include these.
-# # Install GI overrides for python 3 as well
-# install -dm 755 "${pkgdir}"/usr/lib/python3.3/site-packages/gi/overrides
-# ln -s ../../../../python2.7/site-packages/gi/overrides/Dee.py "$pkgdir/usr/lib/python3.3/site-packages/gi/overrides/Dee.py"
}
# vim: ts=2 sw=2 et: