summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31c9d70af1f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Haruyuki lxz <lxz@ilxz.me>
+
+pkgname=deepin-network-utils-git
+pkgver=0.0.1.r1.15f6cf0
+pkgrel=1
+pkgdesc="Deepin network utils"
+arch=('x86_64')
+url="https://github.com/linuxdeepin/dde-network-utils"
+license=('GPL3')
+groups=('deepin')
+provides=('deepin-network-utils')
+confticts=('deepin-network-utils')
+makedepends=('git')
+source=("${pkgname}"::'git+https://github.com/linuxdeepin/dde-network-utils.git')
+sha512sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ git checkout 15f6cf0
+ qmake
+ make -j4
+}
+
+package() {
+ cd ${pkgname}
+ make INSTALL_ROOT="${pkgdir}" install
+}