summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6851c410d746..ad71e50f37f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=deepin-sound-theme-git
pkgver=15.10.6.r2.ge3aa7fb
pkgrel=1
-pkgver=15.10.6.r2.ge3aa7fb
-pkgrel=1
pkgdesc="Deepin sound theme"
arch=('any')
url="https://github.com/linuxdeepin/deepin-sound-theme"
+makedepends=('git')
license=('GPL3')
groups=('deepin-git')
conflicts=('deepin-artwork' 'deepin-sound-theme')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-sound-theme/")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-sound-theme/")
sha512sums=('SKIP')
pkgver() {
@@ -19,6 +18,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd $pkgname
make