summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 33 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91508dcda9d8..296982964aaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,37 @@
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
-# PKGBUILD based on extra\deluge's PKGBUILD, adapted for -git version by Berseker
pkgname=deluge-git
-_srcname=deluge
-pkgver=2.0.0b2.dev342.g72d363968
-pkgrel=2
+pkgver=2.0.0b2.dev360.gbe74d96c6
+pkgrel=1
epoch=1
pkgdesc="A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)"
arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
depends=('desktop-file-utils' 'hicolor-icon-theme' 'libtorrent-rasterbar'
- 'python2-twisted' 'python2-pyasn1' 'python2-rencode' 'python2-pyopenssl'
- 'python2-xdg' 'python2-pillow' 'python2-mako' 'python2-chardet' 'python2-six'
- 'python2-setproctitle' 'python2-zope-interface' 'python2-service-identity'
- 'python2-setuptools' 'xdg-utils')
-optdepends=('librsvg: gtk ui'
- 'pygtk: gtk ui'
- 'python2-gobject: gtk ui'
- 'python2-notify: libnotify notifications'
- 'python2-pygame: audible notifications'
- 'python2-dbus: show item location in filemanager'
- 'geoip: display peer locations')
-makedepends=(
- # binary repositories:
- 'git' 'intltool' 'librsvg' 'pygtk'
- # AUR:
- 'slimit2'
-)
+ 'python-twisted' 'python-pyasn1' 'python-rencode' 'python-pyopenssl'
+ 'python-xdg' 'python-pillow' 'python-mako' 'python-chardet' 'python-six'
+ 'python-setproctitle' 'python-zope-interface' 'python-service-identity'
+ 'python-setuptools' 'xdg-utils')
+optdepends=('librsvg: for GTK user interface'
+ 'gtk3: for GTK user interface'
+ 'pygtk: for GTK user interface'
+ 'python-cairo: for GTK user interface'
+ 'python-gobject: for GTK user interface and desktop popup notifications plugin'
+ 'libnotify: for dektop popup notifications plugin'
+ 'python-pygame: for sound notifications plugin'
+ 'python-dbus: for showing item location in filemanager'
+ 'geoip: for displaying peer locations'
+ 'python-distro: for OS platform information')
+makedepends=('git' 'intltool' 'librsvg' 'pygtk' 'slimit-git')
+checkdepends=('python-pytest-twisted' 'python-pytest-cov' 'python-hypothesis'
+ 'python-mock' 'python-gobject' 'python-cairo' 'xorg-server-xvfb'
+ 'gtk3')
provides=('deluge')
conflicts=('deluge')
+BUILDENV=('!check')
source=('git://deluge-torrent.org/deluge.git#branch=develop' # official repository
#'git+https://github.com/deluge-torrent/deluge.git#branch=develop' # mirror
'deluged.service'
@@ -42,30 +42,33 @@ sha256sums=('SKIP'
'26e4d01003804afb197c570175d44ed4dddd443cc1b88ab2d0230ceacfac90c5')
pkgver() {
- cd "$_srcname"
+ cd deluge
local _internalver
local _shorthash
- _internalver="$(python2 version.py)"
+ _internalver="$(python version.py)"
_shorthash="$(git rev-parse --short HEAD)"
printf '%s.g%s' "$_internalver" "$_shorthash"
}
build() {
- cd "$_srcname"
+ cd deluge
- python2 setup.py build
+ python setup.py build
}
-package() {
- cd "$_srcname"
+check() {
+ cd deluge
- python2 setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
+ xvfb-run python setup.py test
+}
+
+package() {
+ cd deluge
- sed -i '1s/$/2/' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/path_chooser_common.py"
- sed -i '1s/$/2/' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/gtk3/path_combo_chooser.py"
+ python setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"