summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d6f01b1588a..d09405193876 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
pkgname="dendrite"
-pkgver=0.6
-pkgrel=2
+pkgver=0.6.2
+pkgrel=1
pkgdesc="A second-generation Matrix homeserver written in Go"
url="https://matrix.org/docs/projects/server/dendrite"
license=("Apache")
@@ -14,22 +14,12 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/dendrite/archive
"$pkgname.sysusers"
"$pkgname.tmpfiles"
"$pkgname.service")
-sha256sums=('3c7ce45cdb6ec9e03ef2d1514ed0e2d585e387e43bc7dc61d277207a5f4f7e15'
+sha256sums=('c86494b835a06fb5740c138c030121104332c9312176bb105e60c6ac7cc1fed8'
'aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035'
'8da956f9fcc7c6ea844cea53c823fcfa4376acf04ecd9bceb1a908a85846c90f'
'8aac18652906202cd2eedbcc5ea68d87a3ece27cfcba13762b66802c046e0e49')
install="$pkgname.install"
-prepare(){
- cd "$pkgname-$pkgver"
- # hotfix for 32 bit, will be implemented in 0.6.1
- sed -i "go.mod" \
- -e "s|github.com/Shopify/sarama v1.29.0|github.com/Shopify/sarama v1.31.0|"
- go mod download "github.com/Shopify/sarama"
- go get "github.com/Shopify/sarama@v1.31.0"
- go get "github.com/eapache/go-xerial-snappy@v0.0.0-20180814174437-776d5712da21"
-}
-
build(){
cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"