summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f321ad851033..49d9cd77daa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=desktop-notifier-bin
_appname=Desktop.Notifier
pkgver=0.0.8
-pkgrel=6
+_electronversion=23
+pkgrel=7
pkgdesc="Application which sent a notifier when data change about a link"
arch=('x86_64')
url="https://github.com/maxgfr/desktop-notifier"
@@ -10,7 +11,7 @@ license=('custom')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron23'
+ "electron${_electronversion}"
'hicolor-icon-theme'
'libx11'
'gdk-pixbuf2'
@@ -27,8 +28,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('bcde59d6d7501d990adfe88f08c9794153df98177da073b80442fab2c8d13abe'
- '92f6e43eb9073907be4aefb955268d8c5316c75fa20ef17181af819b0d760b0b')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"