summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da93607c124e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Michael DeGuzis
+# <mdeguzis@gmail.com> Git package
+# to stay up to date always If
+# there is not update to the AUR
+# package, remember to pass --devel
+# to your AUR helper (common flag).
+
+pkgname=devscripts-git
+_gitname=devscripts pkgver=v2.16.7
+pkgrel=1 pkgdesc="Scripts to make the life of a Debian Package maintainer easier (git-latest)"
+arch=('any')
+url="https://anonscm.debian.org/git/collab-maint/devscripts.git"
+license=('GPL2')
+depends=('dpkg' 'wget' 'sed' 'perl' 'debianutils'
+ 'debhelper' 'perl-timedate')
+optdepends=('sensible-utils: for sensible alternative selection')
+makedepends=('git' 'po4a' 'perl-timedate' 'perl-libwww' 'docbook-xsl'
+ 'perl-file-desktopentry' 'perl-file-basedir'
+ 'perl-parse-debcontrol' 'python-setuptools')
+conflicts=('devscripts')
+provides=('devscripts')
+options=('!makeflags')
+source=('git+https://anonscm.debian.org/git/collab-maint/devscripts.git'
+ 'fixes.patch')
+install='devscripts-git.install'
+md5sums=('SKIP'
+ '110857b0eb4a9dbf57a8b562d992ab33')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+
+ cd $srcdir/$_gitname
+ patch -p0 -i ../fixes.patch
+ make
+
+}
+
+package() {
+
+ mkdir -p $pkgdir/etc/bash_completion.d
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/lib/devscripts
+ mkdir -p $pkgdir/usr/share/devscripts
+
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+
+}