summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09f9f16a69e7..f0e113427f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,32 @@
# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
pkgname=devtools-riscv64
-pkgver=1.2.0
+pkgver=1.4.0
pkgrel=1
pkgdesc='Tools for Arch Linux RISC-V package maintainers'
arch=('x86_64' 'riscv64')
license=('GPL')
url='https://github.com/felixonmars/archriscv-packages'
depends=('devtools')
-depends_x86_64=('qemu-user-static')
-source=(makepkg-riscv64.conf
- pacman-extra-riscv64.conf
+depends_x86_64=('qemu-user-static' 'qemu-user-static-binfmt')
+source=(makepkg-riscv64.patch
+ pacman-extra-riscv64.patch
sogrep-riscv64)
-source_x86_64=('z-archriscv-qemu-riscv64.conf')
-sha256sums=('c8842d83460d44b873ff56c9ee0c982963ff76e5ed13897e5d7b8d7f0ea7c206'
- 'fc933f164d21774e7a1435d9fccf87cb05f7b601e89a2ba54b899b2ce1e809df'
+sha256sums=('2abae300509c2fbae0246f195fb7ffa17c4ad240052f1e60b0bc504de6149685'
+ '1c79f2817f81e18060a37b237bd1ec619af5447d0884d525aa87aa2165df16b2'
'3721d7ca08eae58ef2a9de6d8f9ccf2fae1f330949bbf5f566db4c2efbd06105')
-sha256sums_x86_64=('c59273c423e815e4c27e8486632d80a768adddd172119035d48f7c2fac98a87a')
package() {
install -Dm755 sogrep-riscv64 -t "$pkgdir"/usr/bin/
ln -s /usr/bin/archbuild "$pkgdir"/usr/bin/extra-riscv64-build
+ patch /usr/share/devtools/makepkg-x86_64.conf -i makepkg-riscv64.patch -o makepkg-riscv64.conf
+ patch /usr/share/devtools/pacman-extra.conf -i pacman-extra-riscv64.patch -o pacman-extra-riscv64.conf
install -Dm644 makepkg-riscv64.conf pacman-extra-riscv64.conf -t "$pkgdir"/usr/share/devtools/
if [[ ! "$CARCH" =~ riscv ]]; then
install -dm755 "$pkgdir"/usr/share/devtools/setarch-aliases.d
echo "$CARCH" > "$pkgdir"/usr/share/devtools/setarch-aliases.d/riscv64
-
- # binfmt-qemu-static, but with P flag
- install -Dm644 z-archriscv-qemu-riscv64.conf -t "$pkgdir"/usr/lib/binfmt.d/
fi
}