summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5b6570ca600..e8b4506b6a62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
-# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+# Maintainer: Krystian ChachuĊ‚a <krystiancha@gmail.com>
+
pkgname=dex-git
-pkgver=62.2d158ca
+pkgver=83.864be05
pkgrel=1
-pkgdesc="A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification"
-url="https://github.com/jceb/dex"
+
+pkgdesc='Program to generate and execute DesktopEntry files of type Application'
+url='https://github.com/jceb/dex'
arch=('any')
license=('GPL2')
+
depends=('python')
makedepends=('git' 'python-sphinx')
+
provides=('dex')
conflicts=('dex')
-source=('git+https://github.com/jceb/dex.git')
-sha256sums=('SKIP')
+
+source=("git+https://github.com/jceb/dex.git")
+
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/dex"
echo $(git rev-list --count master).$(git rev-parse --short master)
}
-build() {
- cd "$srcdir/dex"
- make PREFIX=/usr
-}
-
package() {
- cd "$srcdir/dex"
- make DESTDIR="$pkgdir/" PREFIX=/usr install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd dex
+ make install PREFIX=/usr MANPREFIX=/usr/share/man DESTDIR="$pkgdir"
+ rm "$pkgdir/usr/share/doc/dex/LICENSE"
}
# vim:set ts=2 sw=2 et: