summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 26 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e7be9e4df13..92d350bdfb48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,36 @@
-# Maintainer: Sebastiaan de Schaetzen <sebastiaan.de.schaetzen@gmail.com>
+# Contributor: Bug <bug2000@gmail.com>
+# Maintainer: Bug <bug2000@gmail.com>
pkgname=dexed-ide
-pkgver=3.9.4
+_pkgname=dexed
+pkgver=3.9.11
pkgrel=1
pkgdesc="IDE for the D programming language, its compilers, tools and libraries"
arch=(x86_64)
url="https://gitlab.com/basile.b/dexed"
license=('Boost')
-depends=(dcd dscanner)
+depends=(dcd dscanner vte-legacy)
+makedepends=(lazarus git)
+conflicts=(dexed-ide-bin)
checkdepends=()
-source=(https://gitlab.com/basile.b/dexed/-/jobs/572632492/artifacts/raw/setup/output/dexed.$pkgver.linux64.zip)
-md5sums=('d9646cff816913f3c625d3c6c890b78d')
+#source=("https://gitlab.com/basile.b/$_pkgname/-/archive/v$pkgver/$_pkgname-v$pkgver.tar.gz")
+source=("git+https://gitlab.com/basile.b/$_pkgname.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "$_pkgname"
+ cd lazproj
+ lazbuild -B dexeddesigncontrols.lpk
+ lazbuild -B dexed.lpi
+}
package() {
- mkdir -p $pkgdir/usr/bin
- cp $srcdir/dexed-x86_64/{dexed,dastworx} $pkgdir/usr/bin
+ cd "$_pkgname"
+ install -Dm755 "bin/dexed" "${pkgdir}/usr/bin/dexed"
+ install -Dm644 "bin/libdexed-d.so" "${pkgdir}/usr/lib/libdexed-d.so"
}
+