summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76435125daf7..3e2a6f1d6c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,28 @@
pkgname=dfhack
pkgver=0.47.05
-_pkgver=$pkgver-r5
-pkgrel=7
+_pkgver=$pkgver-r6
+pkgrel=8
pkgdesc="memory hacking library for Dwarf Fortress and a set of tools that use it"
arch=('x86_64' 'i686')
url="https://dfhack.readthedocs.io/en/stable/"
license=('custom')
+# ruby will be removed upstream so libxcrypt-compat dependency may soon go too
depends=("dwarffortress=$pkgver" lua protobuf libpng12 libxrandr libjpeg6 freetype2 libglvnd libxcursor libxinerama libxcrypt-compat)
makedepends=('cmake' 'git' 'python-sphinx' 'perl-xml-libxml' 'perl-xml-libxslt')
conflicts=('dfhack-bin' 'dfhack-git')
source=("$pkgname::git+https://github.com/DFHack/dfhack#tag=$_pkgver"
dfhack.sh
- dfhack-run.sh)
+ dfhack-run.sh
+ Wno-restrict.patch
+ order-plugin.patch)
md5sums=('SKIP'
'81f5909c1a32391679f968e40f24d5ca'
- '3853c6f890d3541f710f2c4833a9e696')
+ '3853c6f890d3541f710f2c4833a9e696'
+ '086fc32900f4c6589a06ac1c7acc6e98'
+ '312e8125e2eff898e5f626c505b863bc')
prepare() {
# shellcheck disable=2154
@@ -30,6 +35,12 @@ prepare() {
git remote set-url origin https://github.com/DFHack/dfhack
git submodule sync
git submodule update --init
+
+ cd "$srcdir/$pkgname"
+ # gcc issue - https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105329
+ patch --strip=1 --input="${srcdir}/Wno-restrict.patch"
+ # this issue fixed upstream, remove this patch next release
+ patch --strip=1 --input="${srcdir}/order-plugin.patch"
}
build() {