summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1aac8ec18e7..86d33958bf38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,28 @@
pkgname=dgraph-bin
pkgver=20.11.2
-pkgrel=1
+pkgrel=2
pkgdesc='Fast, transactional, distributed graph database'
arch=('x86_64')
url='https://github.com/dgraph-io/dgraph'
license=('APACHE' 'custom:DCL')
provides=('dgraph')
conflicts=('dgraph' 'dgraph-git')
+install=$pkgname.install
source=("dgraph-$pkgver.tar.gz::$url/releases/download/v$pkgver/dgraph-linux-amd64.tar.gz"
"dgraph-$pkgver.tar.gz.sha256::$url/releases/download/v$pkgver/dgraph-checksum-linux-amd64.sha256"
"https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/licenses/DCL.txt"
- 'dgraph.service'
- 'dgraph-zero.service'
- 'dgraph-ratel.service')
+ "https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/contrib/systemd/centos/dgraph-alpha.service"
+ "https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/contrib/systemd/centos/dgraph-zero.service"
+ "https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/contrib/systemd/centos/dgraph-ui.service"
+ "https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/contrib/systemd/centos/add_dgraph_account.sh")
sha256sums=('e67390524f44dd1c09f45ea1da98c80c32cc9b16a2f411e36a9849b1e88820cf'
'6e95c6553c193a832f989b8f1f7518ea888008e7cb8fc62d609f6f4cc4772643'
'bfdc75136567068dd049c2d226049a57de5f4a1871eab7429c022e95952efb0d'
- '4ef9bc0e7b2b6d1e6adaef343164f974685bbf2538c9c1ed26ea82d7dddb6974'
- '402c5a022615f47d26db47f375f242638d04abbed3bfd22f86067f8f19031f83'
- '5e0cefcfa0d86ae896383bc76df46cdf28933aabf06918d89269b3b6b4b0e1db')
+ 'b0436225ea1b65e47cea0e4bc039bcf5c795330f352b6333a99e84f5bd000d23'
+ '1d717b444a2bd4a6a5bfe035c8e46bba8319793f9ca211c3d815fa24327dc37f'
+ '6403752fc7d99539236c6b6c81763b3a85a8ceb25959feddcd9f66a0adf8a77f'
+ 'cf80944157c7af97d0bcd18a6d4b5f6a4ba14941f47ff8b19977b7477ee2b865')
package() {
cd "$srcdir"
@@ -31,10 +34,10 @@ package() {
for binary in dgraph dgraph-ratel badger; do
install -Dm755 $binary "$pkgdir/usr/bin/$binary"
done
- install -Dm644 dgraph.service "$pkgdir/usr/lib/systemd/system/dgraph.service"
+ install -Dm644 dgraph-alpha.service "$pkgdir/usr/lib/systemd/system/dgraph-alpha.service"
install -Dm644 dgraph-zero.service "$pkgdir/usr/lib/systemd/system/dgraph-zero.service"
- install -Dm644 dgraph-ratel.service "$pkgdir/usr/lib/systemd/system/dgraph-ratel.service"
- install -d "$pkgdir/var/lib/dgraph/data"
+ install -Dm644 dgraph-ui.service "$pkgdir/usr/lib/systemd/system/dgraph-ui.service"
+ install -Dm755 add_dgraph_account.sh "$pkgdir/usr/share/dgraph/add_dgraph_account.sh"
}
# vim:set ts=2 sw=2 et: