summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 24 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a52301bcf799..7c2911b1f7ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
-# Maintainer: Kaley Main <kaleypoole17@gmail.com>
+# Maintainer: Kyle Westhaus <kwesthaus+aur at gmail dot com>
+# Maintainer: Kevin Orr <kevinorr54+aur at gmail dot com>
+# Contributor: Kaley Main <kaleypoole17 at gmail dot com>
+# Contributor: John Trengrove <john at retrofilter dot com>
pkgname=dgraph-bin
-_pkgname=dgraph
-pkgver=1.0.6
+pkgver=1.0.16
pkgrel=1
-pkgdesc='a low latency, high throughput, native and distributed graph database'
+pkgdesc='Fast, transactional, distributed graph database'
arch=('x86_64')
url='https://github.com/dgraph-io/dgraph'
-license=('APACHE')
-#depends=('gcc-libs')
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dgraph-io/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-linux-amd64.tar.gz" 'dgraph.service' 'dgraph-zero.service')
-sha256sums=('616a3dc22973c48bbe57036dde5ea91055761f565a22bfbe20b6079fd16a9156'
- '6b9e93aa8cc93fd2d163e9fe963bbde998f624fdf7a558b664079bedcb716444'
- 'b917a94ad1ccf6a5831bf103ccdfac64bfdc617ef00ddf8840069de3e31962bc')
+license=('APACHE' 'custom:DCL')
+provides=('dgraph')
+conflicts=('dgraph' 'dgraph-git')
+source=("dgraph-$pkgver.tar.gz::$url/releases/download/v$pkgver/dgraph-linux-amd64.tar.gz"
+ "dgraph-$pkgver.tar.gz.sha256::$url/releases/download/v$pkgver/dgraph-checksum-linux-amd64.sha256"
+ "https://raw.githubusercontent.com/dgraph-io/dgraph/v$pkgver/licenses/DCL.txt"
+ 'dgraph.service'
+ 'dgraph-zero.service'
+ 'dgraph-ratel.service')
+sha256sums=('c778603e747e98fccf212d823c396f72be28153b7832f3804447f39a4ea6a92f'
+ '9aa6a310369039aa53aa247332c3620888047bb0c6ea1ba692cc3983f9afb04e'
+ 'bfdc75136567068dd049c2d226049a57de5f4a1871eab7429c022e95952efb0d'
+ '94449db0bbd30aca993dbc6486fbec615e2cada7cd3d91e6b99d6a426a5d7ace'
+ '402c5a022615f47d26db47f375f242638d04abbed3bfd22f86067f8f19031f83'
+ '5e0cefcfa0d86ae896383bc76df46cdf28933aabf06918d89269b3b6b4b0e1db')
package() {
cd "$srcdir"
- for binary in dgraph; do
+ install -Dm644 DCL.txt "$pkgdir/usr/share/licenses/$pkgname/DCL.txt"
+ for binary in dgraph dgraph-ratel badger; do
install -Dm755 $binary "$pkgdir/usr/bin/$binary"
done
install -Dm644 dgraph.service "$pkgdir/usr/lib/systemd/system/dgraph.service"
install -Dm644 dgraph-zero.service "$pkgdir/usr/lib/systemd/system/dgraph-zero.service"
+ install -Dm644 dgraph-ratel.service "$pkgdir/usr/lib/systemd/system/dgraph-ratel.service"
install -d "$pkgdir/var/lib/dgraph/data"
}