summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b560a9b476ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lth <manuelung@gmail.com>
+# Contributor: nizox <nizzox@gmail.com>
+pkgname=dhcpcd-ui
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="dhcpcd Monitor in GTK+"
+url="http://roy.marples.name/projects/dhcpcd-ui"
+license=("BSD")
+depends=("gtk2" "libnotify" "dhcpcd-dbus>=0.6.0" "hicolor-icon-theme")
+install=dhcpcd-ui.install
+source=(http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2)
+arch=(i686 x86_64)
+md5sums=('6cd085cdf7f9c2bd9b98029edc1d712c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --icondir=/usr/share/icons --without-qt
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir/" AUTOSTARTDIR=/etc/xdg/autostart install
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ sed -n '1,/^$/p' src/dhcpcd-gtk/main.c \
+ >"$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}