summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed0180db6639..8b9b5282bc12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=dht
pkgver=0.24
-pkgrel=2
+pkgrel=3
pkgdesc="BitTorrent DHT library"
arch=('i686' 'x86_64')
url="https://github.com/transmission/dht.git"
license=('MIT')
+makedepends=('cmake' 'git')
source=("git+$url#branch=post-0.24-transmission")
sha256sums=('SKIP')
@@ -17,6 +18,6 @@ build() {
}
package() {
cd $srcdir/dht
- make DESTDIR=$pkgdir install
- install -D dht.h "${pkgdir}"/usr/include/dht/dht.h
+ make DESTDIR=${pkgdir} install
+ install -D LICENCE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}