summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c23954a02c1..fb9cefb210c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@ pkgname=dialer-phonepi
pkgver=1
pkgrel=10
pkgdesc="Dialer application and call daemon for PhonePi project"
-url="https://github.com/PhonePi"
+url="https://gitlab.com/PhonePi"
arch=("i686" "x86_64" "armv6h")
license=("GPL2")
makedepends=("git" "cmake")
depends=("qt5-base" "qt5-tools" "qt5-declarative" "qt5-quickcontrols" "qt5-wayland" "glib2" "dbus" "dbus-glib")
-source=(git://github.com/PhonePi/phonepi.git)
+source=('git+https://gitlab.com/PhonePi/Phone')
sha256sums=("SKIP")
build() {
- cd "$srcdir/phonepi/src/phone/daemon"
+ cd "$srcdir/Phone/src/phone/daemon"
cmake . -DCMAKE_INSTALL_PREFIX=/usr
make
- cd "$srcdir/phonepi/src/phone/qt"
+ cd "$srcdir/Phone/src/phone/qt"
qmake
make
}
package() {
- cd "$srcdir/phonepi/src/phone/daemon"
+ cd "$srcdir/Phone/src/phone/daemon"
make DESTDIR=$pkgdir install
- cd "$srcdir/phonepi/src/phone/qt"
+ cd "$srcdir/Phone/src/phone/qt"
install -Dm755 "./phone" "$pkgdir/usr/bin/phone"
install -Dm600 --owner=$USER "./phone.desktop" "$pkgdir/$HOME/.local/share/applications/phone.desktop"
install -Dm600 --owner=$USER "./phoneicon.ico" "$pkgdir/$HOME/.local/share/icons/phoneicon.ico"