summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51d876a3c100..a802c74c1d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
pkgname=diff-pdf
-pkgver=0.4.1
+pkgver=0.5.2
pkgrel=1
pkgdesc='A simple tool for visually comparing two PDF files'
-arch=('x86_64')
+arch=(x86_64)
url="http://vslavik.github.io/$pkgname"
-license=('GPL')
-depends=('poppler-glib' 'wxgtk2')
-source=("https://github.com/vslavik/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
- remove-cairo.patch)
-sha256sums=('0eb81af6b06593488acdc5924a199f74fe3df6ecf2a0f1be208823c021682686'
- '26027109e4e685d5ecf3d733e9b8ab334c54720056a5bcaebd6b1d2e5f6ef65a')
+_url="https://github.com/vslavik/$pkgname"
+license=(GPL)
+depends=(poppler-glib
+ wxwidgets-gtk3)
+makedepends=(wxwidgets-common)
+_archive="$pkgname-$pkgver"
+source=("$_url/releases/download/v$pkgver/$_archive.tar.gz")
+sha256sums=('7d018f05e30050a2b49dee137f084584b43aec87c7f5ee9c3bbd14c333cbfd54')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 < ../remove-cairo.patch
- aclocal
- autoconf
- automake --add-missing --copy --foreign
+ cd "$_archive"
+ ./bootstrap
+ # Use /usr/share/aclocal/wxwin.m4 from wxwidgets-common
+ rm -f admin/wxwin.m4
+ cp /usr/share/aclocal/wxwin.m4 admin
}
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
+ cd "$_archive"
+ ./configure --prefix /usr \
+ --with-wx-config=wx-config
make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
}