summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9d82e0db906..ae80f7076551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,13 @@
pkgname=diffr
pkgver=0.1.5
-pkgrel=2
+pkgrel=3
pkgdesc='Word-by-word diff highlighting tool'
arch=('i686' 'x86_64') # please write me to add more architectures if you test them and they work
url="https://github.com/mookid/diffr"
license=('MIT')
conflicts=('diffr-git')
makedepends=('cargo' 'git')
-optdepends=(
- # This is subjective, but I don't want to force everyone
- # to install pandoc (+350Mb disk space), just for one manual page.
- 'pandoc: to generate the manual at build time'
-)
source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
b2sums=('0e4bc406a8eb6f2347c9d760f8d2dacd4a258ecd73ffceb0314f1ab8e146db2acce60363c0eed48c8a28983ce95f695d2775780a987bee7bc4ddd5ebaf4d7ec3')
@@ -29,9 +24,6 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
- if command -v pandoc &> /dev/null; then
- pandoc -s -t man assets/diffr.1.md -o assets/diffr.1
- fi
}
check() {
@@ -46,7 +38,4 @@ package() {
cd "${pkgname}-${pkgver}"
install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
- if test -e "assets/diffr.1"; then
- install -Dm644 "assets/diffr.1" "${pkgdir}/usr/share/man/man1/diffr.1"
- fi
}