summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c6d35f736e7..e84899d72b00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=diodon-git
-pkgver=1.9.0.r0.g396cd4d
+pkgver=1.10.0.r0.g3dde466
pkgrel=1
pkgdesc="GTK+ clipboard manager"
arch=('x86_64')
@@ -9,9 +9,9 @@ url="https://launchpad.net/diodon"
license=('GPL2')
depends=('gobject-introspection' 'libappindicator-gtk3' 'libpeas' 'xorg-server-xvfb' 'zeitgeist')
makedepends=('cmake' 'git' 'meson' 'vala')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
-source=($pkgname::git+https://github.com/diodon-dev/diodon.git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+https://github.com/diodon-dev/diodon.git")
md5sums=('SKIP')
pkgver() {
@@ -21,9 +21,9 @@ pkgver() {
prepare() {
cd $pkgname
- # Comment out the following lines to enable the build tests
- rm -rf tests/*
- touch tests/meson.build
+
+ # Patch version check
+ sed -i "s/appindicator_dep = dependency.*ayatana-appindicator3-0.1', version: .*/appindicator_dep = dependency('appindicator3-0.1', version: '>=0.3.0')/" meson.build
}
build() {