summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b51a54c69a66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Timothy Rice <t.rice@ms.unimelb.edu.au>
+
+pkgname=direvent
+pkgver=5.0
+pkgrel=1
+pkgdesc="Deamon that monitors events in the file system directories"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org.ua/software/direvent/"
+license=("GPL")
+depends=('glibc')
+install=$pkgname.install
+source=("http://ftp.gnu.org/gnu/direvent/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1fbd26ce98a4e752e82c3b5a0ae85d3360f1fb273c5ef373dc1c55e3c30824c4')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}