summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8aa198ae6adf..38d8b26800ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="${pkgname%-git}"
pkgver() { git -C "$_name" describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\(alpha\)\([0-9]\+\)/\1_\2/'; }
pkgver=0.4.2.beta1.r0.1f3fc77
-pkgrel=2
+pkgrel=3
pkgdesc='Web path scanner/fuzzer, written in Python'
arch=('any')
@@ -21,6 +21,7 @@ depends=('python' 'python-certifi' 'python-chardet' 'python-urllib3' 'python-cry
'python-pysocks' 'python-cffi')
changelog=CHANGELOG.md
+backup=("etc/$_name/default.conf")
source=("git+$url.git")
sha256sums=('SKIP')
@@ -29,6 +30,11 @@ package() {
cd "$_name"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 *.md -t"$pkgdir/usr/share/doc/$_name/"
+ # hack to fix the default.conf file location
+ local py_ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
+ install -dm755 "$pkgdir/etc/$_name"
+ mv "$pkgdir/usr/lib/python$py_ver/site-packages/$_name/default.conf" "$pkgdir/etc/$_name/"
+ ln -s "/etc/$_name/default.conf" "$pkgdir/usr/lib/python$py_ver/site-packages/$_name/"
}