summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50cae8eecb10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Matei Cotocel <mcotocel at outlook dot com>
+pkgname=discocss-git
+pkgver=v0.1.0.r1.g764db56
+pkgrel=1
+pkgdesc="A tiny Discord CSS injector"
+arch=('any')
+url="https://github.com/mlvzk/discocss"
+license=('MPL2')
+groups=()
+makedepends=('git')
+source=("git+https://github.com/mlvzk/discocss")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm775 discocss "${pkgdir}"/usr/bin/discocss
+}