summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a1cfd31628b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: JianQing Liu <admin at pegasis dot site>
+pkgname=discord-chat-exporter-cli
+pkgver=2.23
+pkgrel=1
+pkgdesc="Export message history from a Discord channel to a file"
+arch=('any')
+url="https://github.com/Tyrrrz/DiscordChatExporter"
+license=('GPL')
+depends=('dotnet-host')
+makedepends=('unzip')
+source=("$pkgname-$pkgver.zip::https://github.com/Tyrrrz/DiscordChatExporter/releases/download/$pkgver/DiscordChatExporter.CLI.zip"
+"discord-chat-exporter-cli")
+noextract=("$pkgname-$pkgver.zip")
+md5sums=('6dce0b7cb0ef2065018fa66c313ae838'
+'0fd85e697c523e950228ab4c30917d71')
+BUILDENV+=('!check')
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p "$srcdir/unzip"
+ cd "$srcdir/unzip"
+ unzip -q "$srcdir/$pkgname-$pkgver.zip"
+ rm "$srcdir/$pkgname-$pkgver.zip"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt/"
+ mv "$srcdir/unzip" "$pkgdir/opt/discord-chat-exporter-cli"
+ install -m755 discord-chat-exporter-cli "$pkgdir/opt/discord-chat-exporter-cli/"
+ mkdir -p "$pkgdir/usr/bin/"
+ ln -s "/opt/discord-chat-exporter-cli/discord-chat-exporter-cli" "$pkgdir/usr/bin/discord-chat-exporter-cli"
+}